Jump to content
  • Advertisement
Sign in to follow this  
cppcdr

Wierd culling problem

This topic is 3753 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, i've started working on the terrain rendering part of my code base and have found a wierd error. When the terrain is looked at in the positive Z axis (camera looking at +Z), the terrain seems to be half transparent: Wierd culling problem The next shot shows the terrain looking from the other side (camera looking at -Z), the terrain is fine. Wierd culling problem Now, the most wierd part of this is that when i look at the +X axis, the terrain renders fine on one half, and bizarrely on the other! Wierd culling problem I have disabled culling and the results are the same. Even in wireframe, the same thing happens. Can anyone tell me what this problem is coming from? I'm really stuck atm.

Share this post


Link to post
Share on other sites
Advertisement
Are you not writing to the depth buffer? Are you not testing against the depth buffer when rendering?

Share this post


Link to post
Share on other sites
Omg! I feel like a total fool :) I forgot to set the depth buffer.

Thanks for your help.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!