Jump to content
  • Advertisement
Sign in to follow this  
maya18222

effect rendering error

This topic is 3752 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Can anyone tell me what im doing wrong here, this effect is rendering to the buffer, (viewport), when is should be rendering to only the render target technique VertexTextured < string Script = "Pass=p0;"; > { pass p0 < string Script = "Draw=geometry;" "RenderColorTarget0 = tex"; > { VertexShader = compile vs_2_0 velvetVS(); ZEnable = true; ZWriteEnable = true; ZFunc = LessEqual; AlphaBlendEnable = false; CullMode = None; //fillmode = wireframe; PixelShader = compile ps_2_a velvetPS_pass_t(); } }

Share this post


Link to post
Share on other sites
Advertisement
There's no effect states you can set that will control which render-target the device will output to. This has to be set in your application code using IDirect3DDevice9::SetRenderTarget.

Share this post


Link to post
Share on other sites
sorry, i forgot to mention, that im in FXComposer,

i know this wont work with my application, but i believe i have used the correct fxcomposer script

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!