Advertisement Jump to content
Sign in to follow this  
AshleysBrain

Directsound & effects - crash on exit

This topic is 3870 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

C++ / Unmanaged / VS2008 / DirectX 9 I'm using Directsound with some of the standard effects (specifically environmental reverb). I've written code to turn on effects (via SetFX), obtain the effect interface (GetObjectInPath), and set the parameters (SetAllParameters) or in the case of environmental reverb, SetPreset. For the most part this works fine at runtime, except it is unstable: - Sometimes the effects simply stop being heard and unprocessed audio is played instead. - Often it crashes on exit in dsound.dll, with no symbols in the call stack (just kernel32.dll above it). No HRESULTS ever return failed error codes. I've put the slider for 'Directsound debug level' to maximum in the DirectX control panel but nothing is ever outputted to the output window in the debugger. I've picked through the documentation and can't find anything I'm doing wrong. I'm stuck! Does anyone have any ideas?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!