Jump to content
  • Advertisement
Sign in to follow this  
Gaiiden

[web] CGI error with WordPress

This topic is 3687 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Alright web gurus, I'm looking for some assistance. I have a site with Brinkster, and one of their services is the ability to run WordPress for a site blog. They gave me clear-cut setup instructions I followed to the letter, and everything seemed to install just fine - except I would see this a lot at the top of pages in the admin section:
Notice: Undefined index: REQUEST_URI in C:\Sites\premium3\gaiiden\webroot\blog\wp-settings.php on line 81
Then, I don't know what I did - it may have been when I edited the date of a post back to 2006 because I was porting over posts from my journal here on GDNet, and wanted the dates to be accurate. After that I couldn't click on any of my pages or categories without seeing the error
CGI Error

The specified CGI application misbehaved by not returning a complete set of HTTP headers.
Now, I did my homework on the WordPress forums and internet, and it turns out to be somewhat of a general PHP problem. I did a phpinfo call and my server is running v5.2.5 with the CGI/FastCGI API, which I hear is one of the causes of the problem. Over at WordPress they suggested a fix to a database file, I tried it and it didn't work. Oh yea, I have v2.5.1 of WordPress installed, and the server instructions did tell me to download v2.2 - so it may be a compatibility issue? I'll ring up their live chat... In the meantime anyone have any ideas? Or should I just go beg and plead over at the WordPress boards if the version difference theory doesn't pan out?

Share this post


Link to post
Share on other sites
Advertisement
The first issue is easy to fix: Just configure PHP to not report notices. There are various ways you can do that, but the easiest is probably to add error_reporting(E_ERROR | E_WARNING | E_PARSE) to the appropriate place in the wordpress code. Ask on the wordpress forums for the right place to add this.

I have no idea about the second issue.

Share this post


Link to post
Share on other sites
Looking at the response headers, the server seems to run IIS 6. As far as I'm aware the REQUEST_URI header is not (guaranteed to be) available for that particular web server. I must say that I'm somewhat surprised that a widely used system as WordPress has not implemented a workaround for it though.

The missing header issue sounds more serious. It looks like either PHP/CGI is not configured properly with IIS (unlikely), or that Brinkster redirects and modifies the original client request and the accompanying headers.

Conclusion: I'm only able to make educated guesses, and I have no ready-made solutions to offer. :/

Both WordPress and Brinkster should be able to shed some light in this online darkness.

Share this post


Link to post
Share on other sites
thx guys, I haven't had time yet to look into this further and I'm away for the weekend but hopefully next week I can work on shedding some light here

Share this post


Link to post
Share on other sites
Well I finally got some free time to talk with Brinkster, turns out it was me using permalinks that was causing the problem. Apparently ISS doesn't support them or something along those lines. Rather gay but, hey it's MS right? They also told me how to turn off the warnings, so everything is all good... for now. I still have to set up more stuff and change the template and all that - plenty more opportunity for getting into trouble! [smile]

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!