Jump to content
  • Advertisement
Sign in to follow this  
oscarsweatman

WM_MBUTTONDOWN message not received on certain mice

This topic is 3747 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've been trying use the middle mouse button (which is clicking my mouse wheel in this case) in one of my apps. I've done middle button events before but that was on a different computer and a different mouse. I'm using the WM_MBUTTONDOWN event in my WndProc function and i receive it fine on lots of mice, just not my Dell mouse that I currently have. My mouse: Dell RP962 / PY777 Optical 5-Button USB Mouse w/ Scroll Wheel (MOA8BO) This is all being done in C++ and Win32. Does anyone know if theres an issue here with manufacturer or if theres multiple message cases i should check for? Thanks.

Share this post


Link to post
Share on other sites
Advertisement
I've never seen that before, it sounds like a hardware / driver issue to me. Does the middle mouse button work in other apps?

Share this post


Link to post
Share on other sites
Yes, the middle button on this mouse does work in other applications, but DOES NOT work in ALL the same places as many other mice. Because of that, I figured this would be a more popular problem.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!