Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Warden

Strange DX problem

This topic is 6318 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m woking on a 2D engine and I''m scaling everything to make sure things look similar no matter what the resolution (just quality degrades as you go down in resolution). What''s happening though is that on my DX8.0/GeForce system, the scaling is sampling outside the bitmap (it''s taking the frames) and I''m getting nasty lines on my sprites (on the right side of several frames and on the top of tiles). But, on my other machine which is DX7.0 with an old diamond card, this doesn''t happen. Anyone encountered a similar problem? Anyone know how to fix it? Anyone know if its a hardware accelerated scaling problem, and if so how to disable hardware accellerated scalling? Any help would be appreciated. Thanks! -Warden

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!