Archived

This topic is now archived and is closed to further replies.

_YEA_H_

Would anyone tell me why??

Recommended Posts

when I compile the source codes supplied by the article of < Code on the Cob> under VC 6.0 plus DirectX 8.0 SDK, an error that tells me "DirectInputCreate" is an undeclared identfier occurs. but I do include dinput.h and link "dinput.lib" in project, would anyone tell me why?? thanks. #ifndef _YEA_H_ #define _YEA_H_ #endif Edited by - _YEA_H_ on June 6, 2001 6:32:56 AM

Share this post


Link to post
Share on other sites
I remember something about doing this:

#define INITGUID

or linking to a lib//dll

.Have a look at the SDK.

What the hells!

Share this post


Link to post
Share on other sites
#include //argh if I put ''<'' the thing between ''<'' nd ''>'' it isn''t shown "windows.h"
#include //same thing: "D3DX8.h"

// This is caused the d3d8.lib to be linked in, the same thing can be accomplished by
// adding it to your compiler''s link list (Project->Settings->Link in VC++),
// but I prefer this method.
#pragma comment(lib,"d3d8.lib")

Sorry I copied this literally from a site but it should work

Share this post


Link to post
Share on other sites
quote:
Original post by _YEA_H_

when I compile the source codes supplied by the article of < Code on the Cob> under VC 6.0 plus DirectX 8.0 SDK, an error that tells me "DirectInputCreate" is an undeclared identfier occurs. but I do include dinput.h and link "dinput.lib" in project, would anyone tell me why?? thanks.

#ifndef _YEA_H_
#define _YEA_H_
#endif

Edited by - _YEA_H_ on June 6, 2001 6:32:56 AM


Push a little bit higher



#ifndef _YEA_H_
#define _YEA_H_
#endif

Share this post


Link to post
Share on other sites
To Katanatje (and others) (a bit offtopic):

that is because the < and > characters are treated specially by the html engine.

write like the following to make it look right:

#include &lt;windows.h&gt;

(lt == Less Than, gt == Greater Than)
and it will look like:

#include <windows.h>

(btw, to write the & character above I used &amp; (=ampersand) to prevent them from being interpreted as </>

Edited by - Dactylos on June 7, 2001 1:27:35 AM

Share this post


Link to post
Share on other sites
I don't know anything about the code on the cob code, but if its using DirectX 7.0 or less, you'll need to define this before the dinput.h include: -

#define DIRECTINPUT_VERSION 0x0300

and possibly this: -

#define INITGUID

This allows previous DX7 projects to be compiled under DX8. Also, make sure that your lib and include files are included properly in your project. Go to Project->Settings and then the Link tab. In the box marked Object/Library Modules, check that your lib files are present.

Hope this helps ya.

RM.



-=Kicking Butt and Writing Code=-

Edited by - RageMatrix on June 7, 2001 5:14:18 AM

Share this post


Link to post
Share on other sites