• Advertisement

Archived

This topic is now archived and is closed to further replies.

Guest Anonymous Poster

DInput exclusive-mode mouse problems

This topic is 6631 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hmmm, i don't think there's away around the problem you described. i guess you can't use it in exclusive mode, like you said. or you can get another computer and remote debug =) the second doesn't have to be powerful at all, i remote debug on a P166 with old matrox (and this is for 3d stuff)...

------------------
http://members.xoom.com/mutex0

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
I know that when I put a DInput device like the mouse in exclusive mode, it is my responsibility to release and acquire it when given certain messages, which I do. And for the most part, my app behaves well with alt-tabbing, ctrl-alt-deleting, etc. However, I am experiencing one frustrating inadequacy right now. When I set a debug breakpoint, and hit it, the mouse is not getting released, so I have no mouse to work with in the debugger!! So, my question is, how do I detect a "debug break" type event/message and properly release the mouse device? Or do I have to not use the mouse in exclusive mode if I plan on debugging? This is local debugging, btw, obviously :^).

Thanks,
N.Treat

Share this post


Link to post
Share on other sites

  • Advertisement