Jump to content
  • Advertisement
Sign in to follow this  
Robo-Link

[java] Jar file won't run

This topic is 3605 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Okay, for some stupid reason my Jar file won't run at all. It doesn't even say anything in the cmd window, nor a pop-up error. Anyway, can someone tell me wtf is wrong with it? It was created using: jar.exe -cmd Manifest.txt ps.jar *.class *.png. http://rapidshare.com/files/136387042/Ps.jar.html

Share this post


Link to post
Share on other sites
Advertisement
Did you execute the JAR through the command prompt or just double click the icon? This would be done with "java -jar [Name].jar" and that should give you an error message if something is wrong. My JAR commands usually go something like this:

jar cvfm [Name].jar manifest.txt *.class *.png *.whatever

I have never compiled a JAR on a Windows machine though (I use Terminal on a Mac), so I am unfamiliar with how that goes...

Share this post


Link to post
Share on other sites
I've only used jars for applets and also use the format:

jar cfmv [name].jar Manifest.txt *.class

Did you remember to include a newline at the end of the manifest file?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!