Jump to content
  • Advertisement
Sign in to follow this  
Quat

PIX crashing debug pixel

This topic is 3569 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to debug a pixel shader for volume rendering. PIX always crashes when I select a fragment to debug. Any ideas? I am using the March SDK version.

Share this post


Link to post
Share on other sites
Advertisement
I noticed that if I turn off the D3D debug runtime in the DX control panel, then it works. Can anyone confirm that this is necessary?

Share this post


Link to post
Share on other sites
Well programs that run fine in debug w/ no leaks or what not regularly give me unexplained crashes in PIX, so I can only assume it's riddled with bugs.

Share this post


Link to post
Share on other sites
First of all I'd suggest downloading the August 2008 SDK. I haven't installed it yet, but the readme talks a lot about PIX changes.

Secondly, I'd like to ask what GPU you're using. I've had this problem with Intel 915 on my subnotebook, but not with NVIDIA or ATI desktop machines. If you can see this on a more up to date chip (and with the latest SDK), that might help Microsoft recreate the problem on their side.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!