Jump to content
  • Advertisement
Sign in to follow this  
grunt123

question about PIX debugging

This topic is 3648 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

My game is currently displaying weird shadow/alpha blending after playing it for a while (5-10min) I think render-targets get somehow corrupted during gameplay. When i capture it with PIX tho, the framebuffer (d3d surface) rendered by last rendering primitive has nothing wrong. ... I'm a bit confused here. I see the visual corruption in the game, but don't see it in PIX capturing. Any idea?

Share this post


Link to post
Share on other sites
Advertisement
Comparison screenshots (one of the actual in-game view with artefacts, and one of the pix capture) might help understand what's going on.

Share this post


Link to post
Share on other sites
Which version of the DirectX SDK are you using as well? I would recommend moving to the August SDK if you haven't already and see if the problem persists.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!