• Advertisement

Archived

This topic is now archived and is closed to further replies.

Guest Anonymous Poster

Diamond Viper 770

This topic is 6622 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
Download the latest drivers. If performance was that bad, it probably came with terrible OpenGL drivers. But I don't know what to tell you about the DX performance...maybe that's another driver thing too.

Share this post


Link to post
Share on other sites
May be you have to install the latest
ICD OpenGL drivers for your game and /or
your graphics card.

Make sure that there is no trouble with
your installed DirectX drivers.
Try to use DirectX 7.0 and your latest
drivers for your graphics card.

Share this post


Link to post
Share on other sites
There is a solution!
I had the same problem until a friend of mine told me to download the latest drivers at www.nvidia.com. Should be something named Detonator X.XX (where x stands for the version-number). These drivers are optimized for the TNT2 chipset so you should not encounter any problems. After I installed them, Quake run soft and smoothly. Before, however, it run at aprox. 1 fps. And don't worry that the drivers aren't from Diamond. They're even better... (well, I might be wrong.)

//----//
blah...

Share this post


Link to post
Share on other sites
Check if Diamond drivers are Windows Hardware Quality Labs certified i.e.(WHQL), if yes they should let the card buffer only 1.5 frames ahead, not 100's of frames ahead like my Permedia2 from CreativeLabs did. I installed reference drivers(WHQL) from 3DLabs and no problems. Driver people cheat on non-interactive benchmarks by buffering more frames ahead to give them higher fps ratings. I had to insert DDFLIP_DONOTWAIT flag and that caused the immediate return from the flip function so my input keys could be read, otherwise you wait until the card buffers frames before it returns from the flip function, I think Have fun.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
I have a Pentium II 200mhz and I just bought a Diamond Viper 770 (TNT2 w/32MB) to replace my aging STB Velocity (Riva 128). I installed the drivers from the CD and reinstalled Quake 2 and tried to play the GL version. It's choppy and slow! What the hell??? To add to that, the tile based engine that I wrote using DirectX gets half the fps it use to. What gives? I was hoping the new video card would boost some fps on either one of those.

Share this post


Link to post
Share on other sites

  • Advertisement