Jump to content
  • Advertisement
Sign in to follow this  

[SlimDX] Installation issues

This topic is 3498 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello! I face two problems with the latest "SlimDX (September 2008).exe" installer. The development PC has VistaSP1 and VS2005 SP1 installed. 1. The minor problem is that after installation "C:\" root directory is flooded with VS2008 runtime files that are not correctly deleted by the installer. 2. The major problem is as follows. As I add reference to SlimDX in VS2005 from .NET list everything seems to be OK. But on application launch I get the following: REGDB_E_CLASSNOTREG: Class not registered (-2147221164) Stack: at SlimDX.Result.Throw[T](Object dataKey, Object dataValue) at SlimDX.Result.Record[T](Int32 hr, Boolean failed, Object dataKey, Object dataValue) at SlimDX.Result.Record[T](Int32 hr, Object dataKey, Object dataValue) at SlimDX.XAudio2.XAudio2..ctor() I already reported the error earlier here. But it still exists. Here are some additional information: 1. the same error is thrown on other PC (WinXP SP2)

Share this post


Link to post
Share on other sites
Advertisement
Sigh. I'm guessing the XAudio bit of the installation is shot again. I'm going to be redoing the installer completely this release...mind waiting a few weeks? (And if you can help me test, that would be nice too.)

Share this post


Link to post
Share on other sites
Of course I can do testing on both Vista and XP PCs.

Actually, I really need to use SlimDX this week. I don't need a full installer, but can you just give me an advice how to cope with the problem? Any solution?

Currently the only working SlimDX library that I use on the developer PC is the one that I built myself in July from the sources. But it doesn't work on user PC either.

Share this post


Link to post
Share on other sites
Thank you, Promit! Your suggestion works just fine.

I'd like to help you with testing, so I'll wait for the new installer and post the results here.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!