Jump to content
  • Advertisement
Sign in to follow this  
ehmdjii

OpenGL shaders with OpenGL 1.4

This topic is 3686 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hello, afaik OpenGL 1.4 can still do shaders, but how? for example the function glCreateShaderObjectARB is only availabel with OpenGL 2.0, right? what syntax do i need to use to get 1.4 compatibility with my shaders? thanks!

Share this post


Link to post
Share on other sites
Advertisement
OpenGL 2.0 is only required for core support of shaders. If you don't have OpenGL 2.0, you have to use extensions instead (which is glCreateShaderObjectARB you mention). You need the extension present in your driver also.

Share this post


Link to post
Share on other sites
glCreateShaderObjectARB is part of an extensions
http://www.opengl.org/registry/

you need
GL_ARB_shader_objects
GL_ARB_shading_language_100

and one of these at least
GL_ARB_vertex_shader
GL_ARB_fragment_shader

These were created before GL 2.0
All GPUs that support these extensions are really DX9 cards and eventually, GL 2.0 drivers were written for them.

If you have GL 1.4, then it is probably a old Radeon 8500 or Intel 950 or something like that.

Share this post


Link to post
Share on other sites
thanks guys,
i will try and use these extensions to get it running with 1.4

Quote:
Original post by V-man
If you have GL 1.4, then it is probably a old Radeon 8500 or Intel 950 or something like that.


yes, it is an intel 950. unfortunately it seems a lot of laptop-users have this card and there are still new laptops sold with this card. that's why i want opengl 1.4 compatibility with my game. :-)

Share this post


Link to post
Share on other sites
ok, so i found that the intel GMA 950 supports

GL_ARB_fragment_program
GL_ARB_vertex_program

but not

GL_ARB_shader_objects
GL_ARB_shading_language_100

does that make sense? what are they two above good for if you cant make shaders without the two below?

thanks!

Share this post


Link to post
Share on other sites
GL_ARB_vertex/fragment_program is different from GL_ARB_vertex/fragment_shader. The first one is a separate, and old, shader interface. Second one is the newer you use with GL_ARB_shader_objects.

Share this post


Link to post
Share on other sites
ah i see the difference now. thanks brother bob.

so how is it possible to get a GLSL shader running with those two extensions only?

Share this post


Link to post
Share on other sites
Cg can compile GLSL code to those assembly forms (GL_ARB_fragment_program, GL_ARB_vertex_program)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!