Jump to content
  • Advertisement
Sign in to follow this  
gogogigo

Alpha Blending

This topic is 3512 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, There's again a problem with alphatexturing:
Some particles (as in the green circle) are rendered correctly, but not the rest(red circle), whose background is that blue (shadered) plane. You can see the black rectangle of the texture, which should be transparent... I don't have any idea why or how to avoid it! (Sorry for my bad english.)

Share this post


Link to post
Share on other sites
Advertisement
As a guess, I'd say you're drawing that blue shaded thing last and using the z-buffer to clip it. But that's just a guess....

Share this post


Link to post
Share on other sites
1.render background with z disable
2.render the rest of the scene with z enable and then
3.render the sprites on top of everything with alpha enabled and z disabled

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!