Sign in to follow this  

Windows sevices and virtual drives

This topic is 3317 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all, a coworker of mine is writing a tool that reports the drives available on the current machine. In addition, that tool should connect to a windows service on a remote machine to get the same informations. The problem is that while the tool correctly recognizes the virtual drives (i.e. a virtual disk on the server or a folder mapped as a device) the service only sees the true drives, even when running on the same pc. My opinion is that the service runs on an account wich doesn't have those mappings. We tried by running it using the same account but it doesn't work. We're using C# for both the tool and the service. Anyone here that have ideas about how to solve it? Please forgive me if this is in the wrong place (in this case, where should I post?) Thank you!

Share this post


Link to post
Share on other sites

This topic is 3317 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this