Sign in to follow this  

Can't Debug Pixel Shader in PIX

This topic is 3314 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Why sometimes I can't debug Pixel Shader in PIX ? I right-clicked on the surface and select "Debug this Pixel", sometimes I got only one result without "Debug Pixel" option in the Debugger Panel: ------------------------------ Final framebuffer value ------------------------------ And sometimes I got this, with which I can continue debugging: ---------------------------------------------------------------------------- Event 1226: IDirect3DDevice9::DrawIndexedPrimitive(D3DPT_TRIANGLELIST, 0, 0, 24, 0, 12)Primitive 12 of 12 Vertex Shader:0x030527E8 Debug Vertex 0 Debug Vertex 1 Debug Vertex 2 Pixel Shader:0x03052778 Debug Pixel (230, 186) ----------------------------------------------------------------------------- Why? I've set D3DXSHADER_DEBUG in my App, and I've set the "DirectX Control Panel" as: 1. Use Debug Version 2. Enable Sahder Debugging 3. Debug Output Level=More What's more, Vertex Shader debugging doesn't work neither with a error message box prompted.

Share this post


Link to post
Share on other sites

This topic is 3314 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this