• Advertisement
Sign in to follow this  

Model Movment Jitters & Anyone used gluUnproject?

This topic is 3409 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I found this very odd, for some reason every time I move my mouse around on the screen it seems that I get more jitters on my models and the animation on the md2 models speed up for some reason a little when the mouse moves. It only happens after a second when the model moves. So is this gimbal locking? My rotation on the model is set up like this:
		glTranslatef(v3Position.m_fX, 0, v3Position.m_fY);
		m_Camera.Set(Vector3(v3Position.m_fX, 30.0, v3Position.m_fY), Vector3(v3Position.m_fX,-10.0f,v3Position.m_fY), Vector3(-1.0f, 1.0f, 0.0f));
		glRotatef(-90, 4.0f, 1.0f, 0.0f); //Rotate model up
		glRotatef(m_Player.GetAngle(), 0.0f, 0.0f, 1.0f); //Move model around via control
		glScalef(0.5f, 0.5f, 0.5f); //Scale model


I don't have a function or anything on WM_MOUSEMOVE, so I am not understanding.. Anyone had the same issue? Question 2 ----------------------- I am trying to get my guy too rotate where the mouse courser is aiming on the screen, my guy is in the middle of the screen the hole time, so I would think I wouldn't need to calculate the player's position. I was told on trying too use gluUnproject, anyone help? [Edited by - ajm113 on November 16, 2008 10:48:12 PM]

Share this post

Link to post
Share on other sites
Sign in to follow this  

  • Advertisement