Sign in to follow this  

COM Object in a service VC8

This topic is 3317 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Window' XP SP2, Visual S'dio 8. -Com component living in an exe as outproc server works fine and is callable from clients. -Registering the exe as a service (was written as a service too) the first client spawns another instance of the exe and uses the object from there instead using the service one. This scenario worked well back on 2000 on windows 2k with VC 4 or VC5. If there are some security issues the error should be not CLASS_NOT_REGISTERED. Any workarounds ? Thank you. [Edited by - gyula on April 13, 2010 10:34:43 PM]

Share this post


Link to post
Share on other sites
Using dcomcnfg, check the local and remote, launch and activation, permissions of your service. If that doesn't work, I'd need to look at the whole rgs file.

It will work fine in XP, and Vista too, if you get it set up right.

Share this post


Link to post
Share on other sites

This topic is 3317 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this