Jump to content
  • Advertisement
Sign in to follow this  
Asheh

Screen flickering from no where!

This topic is 3668 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Im sure ive had this problem years ago, but i cant remember what caused it. For some reason im working on a group project and all of a sudden the screen has started flicering blue/green/red type colours quickly and I am really unsure at what the problem could be. Ive done a bit of googling but no luck so far. Anyone else have any ideas? Ash.

Share this post


Link to post
Share on other sites
Advertisement
Quote:
Original post by Asheh
Im sure ive had this problem years ago, but i cant remember what caused it. For some reason im working on a group project and all of a sudden the screen has started flicering blue/green/red type colours quickly and I am really unsure at what the problem could be.

Ive done a bit of googling but no luck so far. Anyone else have any ideas?

Ash.
You're not clearing the backbuffer, or Clear() is failing. The debug runtimes fill the backbuffer with green or magenta on alternate frames when you use D3DSWAPEFFECT_DISCARD to remind you that the contents of the backbuffer are undefined when using that swap effect.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!