Jump to content
  • Advertisement
Sign in to follow this  
namwkim

How can I erase NOISE in the bump mapped terrain.

This topic is 3672 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Look farther from the screen, we could easily notice noise making our eyes uncomfortable. (too much detail, although not necessary) Maybe we could alleviate bumpmapped effect if terrain is farther from the screen. Does anybody know how to resolve this? The following image is good example what I want to do... http://bp3.blogger.com/_M662VMUvojw/RoEhvNzQptI/AAAAAAAAAG8/BqXXhahZbFk/s1600-h/bumpedTerrain2.JPG

Share this post


Link to post
Share on other sites
Advertisement
Hi,

to me it looks like there is no mip-mapping applied to your textures. I´d try that first.
Besides that applying a bump map effect on the entire scene seems like an overkill to me. Try to use it close to the viewer and disable it for the landscape-tiles that are further away.
If you are using shaders for the bumps you could also try to fade it out on the distance.

Hope that helped,

Ralph

[Edited by - Ekast on November 27, 2008 2:33:23 AM]

Share this post


Link to post
Share on other sites
You eliminate noise by applying a filter. As Ekast says a MIP map (which is a cache of bi/tri-linear filtered textures) would help.

In the image you linked it looks like they turn the bump mapping off for stuff further away. Leaving it on might make the terrain look overly dark in the distance.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!