Jump to content
  • Advertisement
Sign in to follow this  
llamaSong

Pygame Installation/Error

This topic is 3671 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So I downloaded and installed: Python 2.5 Pygame Pyobjc I am running OSX 10.4.11 If I open up IDLE and type import pygame I get the following error: Traceback (most recent call last): File "<pyshell#0>", line 1, in <module> import pygame File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/pygame/__init__.py", line 37, in <module> _check_darwin() File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/pygame/__init__.py", line 34, in _check_darwin raise ImportError("PyObjC 1.2 or later is required to use pygame on Mac OS X") ImportError: PyObjC 1.2 or later is required to use pygame on Mac OS X I'm really not sure what to do.

Share this post


Link to post
Share on other sites
Advertisement
I though the error message is self-explaining enough.

PyObjC 1.2 or later is required to use pygame on Mac OS X

Which version of PyObjC did you grab?
From http://pyobjc.sourceforge.net/downloads.html :

* On Mac OS X 10.5 (Leopard) the stable release is PyObjC 2.0, which is included in the OS distribution. You can also install this from source if you do a checkout of the repository (the repository URL is http://svn.red-bean.com/pyobjc/trunk).
* On earlier releases of Mac OS X the stable release of PyObjC is 1.4, which can be dowloaded from the repository as well (the repository URL is http://svn.red-bean.com/pyobjc/branches/pyobjc-1.4-branch).

Share this post


Link to post
Share on other sites
1.3.7 from here:http://sourceforge.net/projects/pyobjc/

I can't figure out how to download pyobjc from here:
http://svn.red-bean.com/pyobjc/branches/pyobjc-1.4-branch

Share this post


Link to post
Share on other sites
Sorry for the late response, hope you were not waiting for an answer.
Strange that you get this error message if you use a higher version. I don't have a Mac myself so I never really tried it.

As for grabbing the files from this address, it's a SVN repository. You can read on google/wiki about SVN, but in a nutshell it's just a source control software. Many clients exist to use them. On Windows, TortoiseSVN is a fast free and easy choice, but I don't know which one to use for Mac.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!