Jump to content
  • Advertisement
Sign in to follow this  
opticaller

A problem with WindowsXP progrgmmes execution

This topic is 3661 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

The programme I'm working on runs fine on my WindowsXP SP2 environment, whether it's built debug or release. And of cource my environment includes dev-tools such as VC++6.0 and some mobile-dev stuffs. Besides, it dosen't run on other PCs which does not include dev stuffs. At first I've checked some library modules if it's debug-built or built with other run-time libraries. But it was not the problem about debug/release or run-time libraries. So, I've also checked dll dependencies. But I couldn't find a problem with that. While doing such things, I've found something strange. Everytime the programme starts it loads a dll that contains a game. There are a list of games that works with the programme, so I've changed this game module to another. And I've found that it works very well with both environments. So I thought it could be a problem with some games. But like I said, it works fine with dev-tools installed PCs. What could be a problem with this situation? I can't find the way..

Share this post


Link to post
Share on other sites
Advertisement
Thanks for the reply!

That's what I've thought and tried.

I've tried to copy all lists of DLLs that Dependency Walker shows and embed them to testPC's system32. But it doesn't work at all.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!