Jump to content
  • Advertisement
Sign in to follow this  
Kario

Texture shaking and z buffer inaccuracy on mobile ATI

This topic is 3670 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a problem with shaking texture coordinates and very inaccurate zbuffer on mobile ATI, here is the problem: - The problem manifest itself only on long and narrow triangles - Other triangles that do not have a one edge smaller than 2 others don’t have this problem, and are 100% fine - It works fine on all other hardware/software configuration it was tested on - I tried to max graphics setting in catalys driver but with no effect on the problem The problem is very visible because I'm using shadow volumes and because of that parts of those triangles fall behind and in front of its own shadow what I move camera around. I tried biasing a shadow zbuffer (glDepthRange), tried moving all shadows geometry a little in front of camera, move my near plane and all other possible tricks. This looks like maybe a driver is using some kind of optimized path for those triangles (is it possible ??) as is affects only particular triangles.

Share this post


Link to post
Share on other sites
Advertisement
Hm... just a guess, but maybe you use a 16bit zbuffer instead of 32bit ?

Btw, what kind of mobile ati card do you use ?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!