Jump to content
  • Advertisement
Sign in to follow this  
rustycoder

OpenSceneGraph Node Animation (RESOLVED)

This topic is 3611 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hey there smart people, I have some animated models I've exported from blender and when I load them with osg the animation loops. Is there a way to set the node's framestamp manually to control the animation? Thanks in advance! [Edited by - rustycoder on November 29, 2008 8:23:39 PM]

Share this post


Link to post
Share on other sites
Advertisement
Well just to let everyone know, I did come up with a fix. Even though it's different than originally planned, I think it will work out better in the end.

I just split my character animations up into several different files:
standing.osg
run.osg
etc...

Using an osg::Switch group i can just switch between them without worrying about the animation time line. just thought I'd share!

-Rusty

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!