Jump to content
  • Advertisement
Sign in to follow this  
mickeyren

z fighting issue?

This topic is 3609 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi Please see screen shot. Both the x and z axis lies exactly on the same plane as the 3d grid. I'd like my 3d axis lines to always show up. And if i start placing 3d objects on the grid, the grid lines won't fight with the 3d objects as well. I wonder if the right way is to always render my 3d grid lines first with disabled depth buffering. Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement
You could also use depth biasing to bias each entity at a priority in the depth, but disabling depth testing is pretty much the same but faster. The downside is that it requires rendering in the correct order, but it fits perfectly for what you're doing.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!