Jump to content
  • Advertisement
Sign in to follow this  
antifists

Problems with Compiling "Elemental Engine II"

This topic is 3613 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I downloaded Elemental Engine II, along with visual C++ 2005 and the Platform SDK with this tutorial http://www.nuclex.org/articles/setting- up-visual-cxx-express. I followed the tutorial on how to compile it from this website, but when I try, I get these error messages:

--------------------------------------------------------------------------------
1>------ Build started: Project: EESDKLib, Configuration: Release Win32 ------ 1>Compiling... 1>stdafx.cpp 1>Compiling... 1>Vec4.cpp 1>Vec3.cpp 1>Ray.cpp 1>Random.cpp 1>Quaternion.cpp 1>ProxyObject.cpp 1>Plane.cpp 1>Matrix4x4.cpp 1>Matrix3x3.cpp 1>MathUtils.cpp 1>Frustum.cpp 1>FilePath.cpp 1>ExceptionHandler.cpp 1>EulerAngle.cpp 1>EEStdStreamProxy.cpp 1>EEStdStreamBufProxy.cpp 1>EEMath.cpp 1>CSceneObject.cpp 1>CManagerListener.cpp 1>CManager.cpp 1>Generating Code... 1>Compiling... 1>CKeyFrame.cpp 1>CJoystickHandler.cpp 1>CJoystickAxis.cpp 1>CJoystick.cpp 1>AABB.cpp 1>Generating Code... 1>Compiling... 1>dlmalloc.c 1>Creating library... 1>Build log was saved at "file://c:\Users\Jimmy\Documents\Source Treez\trunk\Development\ ElementalEngine2\EESDKLib\Win32\Release\ BuildLog.htm" 1>EESDKLib - 0 error(s), 0 warning(s) 2>------ Build started: Project: ElementalEngine, Configuration: Release Win32 ------ 2>Compiling... 2>StdAfx.cpp 2>Compiling... 2>ProxyManager.cpp 2>PerformanceProfilerHandler.cpp 2>DefaultLogger.cpp 2>CToolBox.cpp 2>CTimer.cpp 2>CPerfTimer.cpp 2>CObjectFactory.cpp 2>CMemoryAllocator.cpp 2>CListenerFactory.cpp 2>CDelayedDeleteListener.cpp 2>C2DLine.cpp 2>CSoundManager.cpp 2>JoystickManager.cpp 2>CMouse.cpp 2>CKeyboard.cpp 2>CInputManager.cpp 2>CInput.cpp 2>CNetManager.cpp 2>CNetConnection.cpp 2>CVertexFormat.cpp 2>Generating Code... 2>Compiling... 2>CTextureCompositer.cpp 2>CShaderPath.cpp 2>CShaderDefines.cpp 2>CParticleType.cpp 2>CParticleSystemObject.cpp 2>CParticleRibbonType.cpp 2>CParticleRibbonRenderObject.cpp 2>CParticleRenderObject.cpp 2>CParticleLineType.cpp 2>CParticleLineRenderObject.cpp 2>CParticleEmitterType.cpp 2>CParticleEmitterObject.cpp 2>CParticleEmitter.cpp 2>CParticleBatchRenderObject.cpp 2>CObjectSceneSettings.cpp 2>CMeshObject.cpp 2>CMaterialTemplate.cpp 2>CMaterialOverride.cpp 2>CMaterial.cpp 2>CLightObject.cpp 2>Generating Code... 2>Compiling... 2>CGeometry.cpp 2>CEffect.cpp 2>CCamera.cpp 2>CBatchGeometry.cpp 2>CAnimatedTexture.cpp 2>CVertexBufferManager.cpp 2>CTextureManager.cpp 2>CSpriteManager.cpp 2>CShaderManager.cpp 2>CSceneVisibilityManager.cpp 2>CRenderManager.cpp 2>CParticleManager.cpp 2>CLightManager.cpp 2>CIndexBufferManager.cpp 2>CFontManager.cpp 2>CCameraManager.cpp 2>MathManager.cpp 2>CWorld.cpp 2>CSceneObjectManager.cpp 2>CHierarchyManager.cpp 2>Generating Code... 2>Compiling... 2>StreamFactory.cpp 2>CXMLArchive.cpp 2>.\src\CXMLArchive.cpp(32) : fatal error C1083: Cannot open include file: 'atlenc.h': No such file or directory 2>CMemStream.cpp 2>CFileStream.cpp 2>CArchiveFactory.cpp 2>CArchive.cpp 2>CTransform.cpp 2>CEntityManager.cpp 2>CEntity.cpp 2>Generating Code... 2>Build log was saved at "file://c:\Users\Jimmy\Documents\Source Treez\trunk\Development\ ElementalEngine2\src\Win32\Release\ BuildLog.htm" 2>ElementalEngine - 1 error(s), 0 warning(s) 3>------ Build started: Project: unitTest, Configuration: Release Win32 ------ 3>Performing Custom Build Step 3>The system cannot find the file specified. 3>Project : error PRJ0019: A tool returned an error code from "Performing Custom Build Step" 3>Build log was saved at "file://c:\Users\Jimmy\Documents\Source Treez\trunk\Development\ ElementalEngine2\UnitTest\Win32\Release\ BuildLog.htm" 3>unitTest - 1 error(s), 0 warning(s) ========== Build: 1 succeeded, 2 failed, 0 up-to-date, 0 skipped ==========

Share this post


Link to post
Share on other sites
Advertisement
Are you sure that the platform SDK is configured properly? Can you successfully compile and run a simple Win32 application?

Also note that if you donwload VC++ 2008 Express, you wan't need to install the platform SDK. It also has some other improvements over 2005.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!