Sign in to follow this  

Project Building Problem

This topic is 3296 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, Im trying to set up the following programming system for my commonly used headers, in which i have a main folder Myapps, and then a subdirectorys. MyApps/Base ---------------- //common headers/cpps i use all the time Texture.h/.cpp Vertex.h/.cpp MeshLoader.h/.cpp etc MyApps/Media ---------------- //all media data meshfiles textures sounds etc Then when i want to create a new project, i just put that project folder in the myapps folder. I then add an extra directory to search for headers in the project settings, which will be Myapps/Base. and also add "..\" to search for the media files. Now these works fine, but unless i choose to also add the base headers and the cpps to the project, as an existing items, i get linker errors. I gather that this is because the .object file is not being created. How do i solve this issue?

Share this post


Link to post
Share on other sites
You could compile your commonly used components as libraries and include the libs into your new projects. That way you wouldn't need to include all the source files to your project and it would skip the need to re-compile them all the time.

Share this post


Link to post
Share on other sites

This topic is 3296 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this