Sign in to follow this  
ucfchuck

interpolation issues

Recommended Posts

ucfchuck    149
interpolation issues im having issues getting the interpolation to work across triangles. as you can see. ive tried all the sampler state interpolation options and this picture was done using this configuration. SamplerState samLinear { Filter = MIN_MAG_MIP_LINEAR;//ANISOTROPIC;//MIN_MAG_MIP_POINT; AddressU = Wrap; AddressV = Wrap; }; how do i get the interpolation to cross over the triangle boundaries??

Share this post


Link to post
Share on other sites
ucfchuck    149
the triangles do share adjacent texture coordinates, each of those lines is a 1d color array of 8 bits in the texture, and each adjacent triangle shares the same 1d line down the sides. these are technically quads that you are seeing made up of two triangles. this example is a little harsh as one of the triangles dissappears as two of its vertices share the same point. but here is another example where the quads are more regular. but the interpolation isnt that grreat.
Photobucket

you can still see the edges of the quads and easily make out data points.
is there any way to write my own that would be over 2 or 3 triangles?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this