Jump to content
  • Advertisement
Sign in to follow this  
samv

[SlimDX] Direct3DEx.Adapters not initialized

This topic is 3500 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Direct3DEx derives from Direct3D and inherits the Adapters property. It also defines a new AdaptersEx property. I'm trying to use a Direct3DEx instance if possible and fall back on a Direct3D instance when this fails. In both cases I'm trying to use the Adapters property, because I don't need any extended information. This fails when using the Direct3DEx instance. It seems that only one Direct3D constructor initializes the Adapters property, and that the Direct3DEx specifically doesn't call that one base constructor. Instead it calls the Direct3D(bool) base constructor that does not initialize said property. Is my expectation (to be able to use the same property in both cases to avoid duplicated code) somehow flawed? Or should the Direct3D(bool) base constructor also initialize said property? Thanks.

Share this post


Link to post
Share on other sites
Advertisement
This is a known bug in the 9Ex implementation that I kinda forgot to fix. I'll hit it in the SVN in the coming days...holidays make it difficult to say exactly when.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!