Archived

This topic is now archived and is closed to further replies.

TeTE

Problem with ... normals?

Recommended Posts

Look the picture at http://www4.uji.es/~al024870/misc/cube.jpg and you will see what''s my problem. It''s a cube with light and a green texture. I use vertex arrays with the vertices, the texture coordinates and the normals. All is read from an OBJ file. And the models are made with Nendo. What''s wrong? May be the normals? I think they are per vertex normals. I have tried more complex objects (airplanes, buildings). All look similar and no one is smooth even with GL_SMOOTH enabled.

Share this post


Link to post
Share on other sites
When you say that you enabled GL_SMOOTH did you do it with glEnable or with glShadeModel? glShadeModel would be the correct one.

If you already did this then the problem probably has to do with the normals you specify. Try specifying only one normal per quad (or one per triangle).

Jason A.
DelphiGL (http://delphigl.cfxweb.net)

Share this post


Link to post
Share on other sites
o Yes, I use glShadeModel.
o The vertices are in counter-clockwise order. And OpenGl is set accord to this.

The problem is that Nendo doesn''t saves the normals correctly. I have converted the files with another program and the objects are correctly illuminated.

But now I have another problem. All is tinted in blue!! I don''t use alpha and nor the light nor the materials have a great blue component. Any idea of what can be the error?

Thanks for all the replies!

Share this post


Link to post
Share on other sites