Jump to content
  • Advertisement
Sign in to follow this  
DWN

Blocking WM_PAINT?

This topic is 3449 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

This is not a mobile dev question, per se, but is more likely to arise in this platform. Environment: MSVC2005 with Windows Mobile 3 emulating ARM4I I am drawing some things to the screen of an emulated mobile device, but it is not appearing. I could be wrong (sleep<HEALTHY), but what appears to be happening is, winProc() is getting called over and over to repaint the window before the screen is drawn, thus the screen is never drawn. (Before calling my main application code, I can draw some pixels, however.) If this is the case, it seems the wndProc() callback is a pain. Is there an easy way to block the WM_PAINT message from arriving at all, and just update the frame myself? Is this a common problem? Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement
I was probably a bit hasty in posting that question - looks like all I had to do was to validate the window.
(not that it is working yet :^>)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!