Jump to content
  • Advertisement
Sign in to follow this  
Njguy

Quick link error

This topic is 3451 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am getting this link error, and I really dont know why. The engien compiles fine, but the app, returns the error on compilation. 1>Linking... 1>engine.lib(Engine.obj) : error LNK2019: unresolved external symbol __imp__NxCreatePhysicsSDK referenced in function "public: __thiscall Engine::Engine(struct EngineSetup *)" (??0Engine@@QAE@PAUEngineSetup@@@Z) 1>.\Debug/Test.exe : fatal error LNK1120: 1 unresolved externals 1>Build log was saved at "file://c:\Documents and Settings\HP_Administrator\Desktop\Source\Chapter 10\Test\Debug\BuildLog.htm" 1>Test - 2 error(s), 0 warning(s) ========== Build: 0 succeeded, 1 failed, 1 up-to-date, 0 skipped ========== This is the source: gPhysicsSDK = NxCreatePhysicsSDK(NX_PHYSICS_SDK_VERSION); if (!gPhysicsSDK) return; Global: NxPhysicsSDK* gPhysicsSDK = NULL; I followed the instructions and the model, so I can't figure out what is wrong.

Share this post


Link to post
Share on other sites
Advertisement
You need to add a .LIB to your linker parameters; in this case it will be one of the LIBs from Ageia's SDK. (I am unfortunately not familiar with this SDK so I can't tell you which one.)

Just click on Project, Properties, Linker, Input and add the LIB file to the list in Dependencies. That should take care of it.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!