Jump to content
  • Advertisement
Sign in to follow this  
vanger

Running Direct3D lib under iis process

This topic is 3495 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have created a D3D lib (it is a COM dll) used for off-screen rendering. And make a web service API. Then people can call the web API and get a snapshot back from their scene (not define yet, just want to run the system first). My target system is windows server 2003 R2. I have test an ordinary D3D application and it ran fine on the machine. However, when I made a call through the web service API that called the D3D to create D3D device, it fail to create the device with unknown error returned, the output for D3D debugger runtime was something like "Graphics hardware acceleration is disabled". This has happened before when I ran the normal D3D application but to fix it, I just went to Display Properties->Settings->Advanced->Troubleshoot and moved the slider bar of "Hardware acceleration from "none" to "full" then the D3D application could run fine. but this does not work with the call from web service API. * When I ran the process explorer, I saw the D3D lib was running under iis process. Is there something to do with it? * I have implemented web service API using C# and D3D lib is in-process COM dll written in C/C++ * My graphics card is geforce7950. * If possible I don't want to migrate in-process COM to out-of-process COM. It is a performance issue. * I have latest graphics driver. Does anybody has a clue about this one? Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!