• Advertisement
Sign in to follow this  

[SOLVED]Yesterdays Textures Work Today's Don't

This topic is 3319 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So yesterday I drew some very primitive textures using paint, and ran them through my application. Cool they work. Today I drew slightly more intricate textures, and decided to put them in my application. No dice. So I test the primitive textures I drew prior, and those still work. The new ones just appear white on my Quad. Does anyone have any idea what this could be from?? Is my image resolution to high(my file size is 16 x 24 with maybe 16 colors...)? I've tried changing them from .bmp to .jpg, to .gif to .png... Still no dice. The texturing method I am using is primitive and similar to NeHe's lesson 6 (for reference : http://nehe.gamedev.net/data/lessons/lesson.asp?lesson=06) , so it's nothing complex by ANY means. And yes I did try googling this and saw nothing pertaining to this error. This is just down-right frusterating... [Edited by - Cakey on January 24, 2009 3:57:17 PM]

Share this post


Link to post
Share on other sites
Advertisement
Maybe your card doesn't support non power of two texture sizes, what where "yesterday's" texture sizes?

Share this post


Link to post
Share on other sites
My working textures work in .png and .gif and .bmp.
The ones today do not work in any of these...

The sizes of yesterdays were, 32 x 32 and 64x32

The only thing I can even think of is a reboot, but I'm knee deep in coding another part of my game and don't wanna lose my spot, or know how much a reboot could even do for me..

Share this post


Link to post
Share on other sites
I tried converting them to 32 x 32, and now they show up. How frusterating!

Seriously though I needed them to be 16 x 24(and 32 x 48 doesn't work...) specifically for it to look best but I'll find a way to work around it I guess.

EDIT: The textures only work in sizes of multiples of 32 for some reason. This is in JOGL in Vista. Hopefully this saves someone some headache, cuz I'm bustin out the tylenol.

Share this post


Link to post
Share on other sites
Quote:
Original post by Cakey
I tried converting them to 32 x 32, and now they show up. How frusterating!

Seriously though I needed them to be 16 x 24(and 32 x 48 doesn't work...) specifically for it to look best but I'll find a way to work around it I guess.

EDIT: The textures only work in sizes of multiples of 32 for some reason. This is in JOGL in Vista. Hopefully this saves someone some headache, cuz I'm bustin out the tylenol.


Well, generally OpenGL likes power-of-two textures, i.e. dimensions like 1,2,4,8,16,32,64 etc. See 24 in that list? If not guess why [grin].

Most likely your driver or JOGL doesn't support non-power-of-two textures. You could use 16x32 instead and adjust the texture coordinates to just use the 16x24 portion.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement