Archived

This topic is now archived and is closed to further replies.

penetrator

enabling/disabling anti-aliasing

Recommended Posts

The extension you need is GL_ARB_multisample:

http://oss.sgi.com/projects/ogl-sample/registry/ARB/multisample.txt

Share this post


Link to post
Share on other sites
that extension is for fullscreen antialiasing. u can also do polygon,line,point antialiasing with eg glEnable( GL_POYGON_SMOOTH )
http://www.frii.com/~martz/oglfaq/ section 14

http://members.xoom.com/myBollux

Share this post


Link to post
Share on other sites
quote:
Original post by penetrator
i enabled the extension with:
#define GL_MULTISAMPLE_ARB 0x809D

and used a
glEnable(GL_MULTISAMPLE_ARB);

but anti-aliasning is always off: am i doing something wrong ?



well.. actually - yes.

You cannot "enable" extension just by defining some constant.
If your 3D board has no such extension, glEnable(GL_MULTISAMPLE_ARB) will do nothing.

btw,
only GeForce3 supports GL_ARB_multisample
(well, we're tolking about consummer-level cards, not Wildcats..).
and you have to choose pixel format with multisample buffer.


Edited by - Serge K on June 30, 2001 8:16:04 PM

Share this post


Link to post
Share on other sites
WGL_ARB_multisample is available on GeForce2's as well as GeForce3's, at least in 12.xx drivers it is.

Jason A.

---
I write code.
DelphiGL (http://delphigl.cfxweb.net)

Edited by - Jallen on June 30, 2001 10:35:47 PM

Share this post


Link to post
Share on other sites