Archived

This topic is now archived and is closed to further replies.

PRGFX_3DLine

This topic is 6015 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ok, I don''t know why this happens, but I use this command to get some information from my programs. What happens is that if I tell it to draw from say 0,0,0 to 10,10,10 I get a line that goes from 0,0,0 to the top left of my screen and then another line from the top left of my screen to 10,10,10. What is really confusing me is that it doesn''t always happen. In a program I have, it works sometimes and periodically switches to not working and then back from not working to working. I know it cannot be my viewmatrix or any of my camera setup because I''m always rendering 3D objects and they look just fine, its only the PRGFX_3DLine which doesn''t draw correctly. Also it appears the order of the rendering of these objects effects the line. For example, if I draw a simple Cube Pro first then the line, at certain points in the program it will stop functioning(but always at the same points each time I run it). If I draw the Cube second, the points at which the 3D line messes up changes. It''s happened in multiple programs and I can''t think of anything I''m doing that would cause this. If a pro can render ok, why can''t the 3D line? Any Ideas? Gary

Share this post


Link to post
Share on other sites