Sign in to follow this  

Creation of Device

This topic is 3196 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I can't seem to find the problem in my code, this is the first Error: // CREATION OF DEVICE ... hr = d3d->CreateDevice( D3DADAPTER_DEFAULT, D3DDEVTYPE_HAL, hwndMain, D3DCREATE_SOFTWARE_VERTEXPROCESSING, &presentParameters, &device ); if( FAILED( hr ) ) { MessageBox( 0, "Error creating D3D device", "Error", MB_OK ); return false; } edit: by making the ifs false the program eventually reach: First-chance exception at 0x00411fe6 in 1.exe: 0xC0000005: Access violation reading location 0x00000000. Unhandled exception at 0x00411fe6 in 1.exe: 0xC0000005: Access violation reading location 0x00000000. by pointing at: device->BeginScene(); edit: having the code like it is, the program ends at the if stated above.. I get a msgbox after that nothing else..

Share this post


Link to post
Share on other sites

This topic is 3196 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this