Sign in to follow this  

AMD code analyst in Visual Studio 2005

This topic is 3199 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all, I installed the AMD code analyst and it automatically integrated with my visual studio environment. Now, for each profiling sample I can obtain the corresponding asm instruction, but I cant automatically get the corresponding c++ code. From what I saw in the documentation, this should be possible. Anyone any suggestions on what I might have forgotten. Do I need to set some special compilation settings for this? Thanx, Dietger

Share this post


Link to post
Share on other sites
Thanx for your replay,
I tried adding my source directory, but that does not seem to help much. I noticed that I only have the problem when compiling the project in Release mode. When compiling with Debug mode, it works fine. Profiling in debug mode is however not very useful.

Share this post


Link to post
Share on other sites
Well, you where right that no pdb-files where generated. But having them enabled does not make any difference. I cant think of any other difference between debug and release mode, other than a few optimization flags.

Share this post


Link to post
Share on other sites
Quote:
Original post by dietepiet
Well, you where right that no pdb-files where generated. But having them enabled does not make any difference. I cant think of any other difference between debug and release mode, other than a few optimization flags.


There's a lot of differences between debug and release modes, one of which is that no debug symbols are created. Maybe try adding that?

Share this post


Link to post
Share on other sites
What you might want to do is copy your Release configuration and call it Profile, and undo the changes you have made to Release. You probably don't want to have debug symbols, etc. active for your Release build.

Good luck!

Share this post


Link to post
Share on other sites

This topic is 3199 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this