Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

pasman

Weird error ??!!!

This topic is 6228 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, for some time i''ve been experiencing some weird stuff goin'' on in my game... I''m writing a turn based strategy game and in battle mode when a unit is firing to another it gives me an ''Access Violation exception'' and the game crashes. After a few traces I found out that dxdraw.surface turned ''nil''. I can''t figure out what is causing this to happen. I don''t use any pointers, all the graphics are correctly loaded and I only draw at dxdraw.surface. I also use turbopixels unit. Can the unit cause it. Thanks

Share this post


Link to post
Share on other sites
Advertisement
Anything (well almost anything) could cause an AV. Are you UNLOCKing the surface after you draw with turbopixels...?



[ Michael Wilson | turbo sys-op | turbo.gamedev.net ]

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!