Sign in to follow this  

OpenAL and source position

This topic is 3150 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi there, I've been playing around with OpenAL and have some problems positioning my source. I finally figured out that the wav file has to be mono and I can position the source to the left and to the right. My listener is at 0.0, 0.0, 0.0 and my source starts there as well which is giving me output on the left and on the right speaker. If i move my source a little bit to the right (x = 0.01) then all of a sudden the left speaker doesn't give me any output and I can only here the right speaker. I want to smoothly fade from left to right, but there is an ugly jump. Any idea?

Share this post


Link to post
Share on other sites
SOLVED.

Turns out that my z-position of my listener and the source were the same. In this case obviously when we move the source to the right the listener would actually block out the left speaker.
I've set my listener z = -1.0f and my source z = 1.0f and it fixed it, woohoo!

Share this post


Link to post
Share on other sites

This topic is 3150 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this