• Advertisement
Sign in to follow this  

x64 samples crashing on Winows 7

This topic is 3193 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello Gamedev! I have installed the March 2009 SDK on a 64 bit Windows 7 Build 7100 and I'm experiencing troubles with running the x64 SDK samples. D3D9 x64 samples crash at startup and D3D10 x64 samples crash when pressing the "Changde device (F2)" button. Anybody else experience these crashes? Any way to fix them?

Share this post


Link to post
Share on other sites
Advertisement
I've not had any issues myself. I just ran half a dozen or so and all the features worked right. If you want to get help troubleshooting the problem, I'd suggest running GPU-Z to give detailed information about your video card drivers. I'm using ForceWare 185.85 on an 8800GT myself. I also have Aero disabled, so try that as well. I noticed a few programs (UltraMon for once) had problems when it was enabled, so I switched to a basic classic theme and things are a bit better.

Share this post


Link to post
Share on other sites
I have discovered that the crashes only occur when using the D3D9 debug runtime. It seems odd that the D3D10 samples are affected by that, but maybe the DXUT relies on some DX9 features.
Heh I don't even know how to disable Aero on Win7, I'll have to look into that.
Could you try switching to the D3D9 debug runtime and see if you can replicate the crashes?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement