Sign in to follow this  

glVertexPointer & Graphics Card

This topic is 3117 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I am using glVertexPointer with and without graphics card. What happens is when we draw a set of objects using glVertexPointer with graphics card FIRST and when we try to draw another set of objects using glVertexPointer without graphics card SECOND, i am unable to view the objects drawn at the SECOND time. Is there any particular reason why this happens... Thanks in advance for your reply... Regards Senthilkumar

Share this post


Link to post
Share on other sites
Its not without Graphics Card, its without VBO concept (glBindBufferARB, glGenBufferARB and so on). Guess you got what I mean. I am very new to this VBO and glVertexPointer concept

Share this post


Link to post
Share on other sites
So what you are saying is, after you draw using VBO, you then draw something using vertex arrays, and you do not see it.

I am not aware of any issues relating to that. I use VBOs and immediate mode interchangeably and it works fine. Note that syntax for glVertexPointer is different for vertex arrays than for VBO. You probably overlooked something in your code, so post the drawing code for both cases. (Use ["source"] and ["/source"] tags, without the quotes).

Share this post


Link to post
Share on other sites

This topic is 3117 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this