Sign in to follow this  

mscoree.dll without /clr switch

This topic is 3112 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi everyone, I'm hitting my head on the table since two days with this problem. Perhaps someone has a clue where to look... I' a VS2008 solution containing several projects. Some of them have been upgraded from Visual Studio versions as old as VS6. One particular project only has been upgraded from VS2005, and it's this one which causes problems. The problem: The executable makes reference to mscoree.dll which is a .Net DLL for managed c++ code. The executable does not need that dll because normally, there should not be any .Net code in it (>800.000 lines of code; haven't read every single LOC). Upon exiting the application, an exception is thrown within the managed code of the above mentioned dll. Normally, managed code compilation is triggered through the /clr switch in Visual Studio. I've verified the command line statements and I cannot see any /clr. Neither is set any visible managed code switch in the properties window. What I remark, though, is that the Framework and References part of the property window is enabled (right click onto project -> properties -> Common properties -> Framework and References) and set to ".Net Framework 2.0". All other projects do not have this panel enabled and the framework selection combobox is disabled. Does anyone know how to find out how the managed code stuff is linked to my application? How to disable the framework target combo box? Best regards and thanks, Stefan

Share this post


Link to post
Share on other sites
Are you sure you have not enabled CLR support in project properties?
Check Project settings -> Configuration Properties -> General -> Common Language Runtime Support. It should be with "No Common Language Runtime support".
When I have this option set to No CLR support, then Framework and References property page have Targeted Framework setting disabled. If I change it to anything else, then this setting is enabled.

Share this post


Link to post
Share on other sites
Yeah, I checked that... but finally I found the problem....

1 out of my 1400+ files had set "Compile as managed". I found this taking a look at the vcproj file of the project causing the problem.

NOTE to self: Slap the guys head who set that flag on ONE file out of 1400+... and no... it's not me...

Thanks,
Stefan

Share this post


Link to post
Share on other sites

This topic is 3112 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this