• Advertisement

Archived

This topic is now archived and is closed to further replies.

Colorfull Mystery!

This topic is 6038 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi! i m new to OGL world n i m having real trouble with colors! some of the times i save my models info in structures or classes including color info but when i set color using glColor() eg: glColor3fv(cube.clr); it seems to have no effect! n the model is simply drawn with previously selected color!! what is all this about? pls help! ----------------------------------------------------------- Well! guies thanks for ur comments but actually there wasn't any problem. it only had to do with some bugs in my program! huh! Edited by - aamishah on July 19, 2001 12:56:47 PM

Share this post


Link to post
Share on other sites
Advertisement
hello !

what primitives do you use ?
some primitives don't allow more then one color, in some cases, i think.

for more, you should post a code.

[edit]
ok,here i got it:
GL_POLYGON uses the first color that is specified.
(in the same glBegin()-glEnd() code).
well, i can't imagine that this is the problem

please post some code





Edited by - LittleTaz on July 12, 2001 6:07:02 AM

Share this post


Link to post
Share on other sites
Hello there,

is lighting on? if it is then you need to change the
material not the color.

To do this enable GL_COLOR_MATERIAL and use the
glColorMaterial function.

Hope it helps

Mark.

Share this post


Link to post
Share on other sites

  • Advertisement