Sign in to follow this  
shultays

a small problem about post processing (i think)

Recommended Posts

Hello again guys I have a small problem in my project. My screen shifts 1 pixel vertically, I mean top of the screens actually shows the bottom line. I am using post processing in my program. But I don't remember if this is happened before. It is hard to notice so I am not sure. I am also using a pixel shader Here is a ss, it is hard to see this here http://img15.imageshack.us/img15/391/41519165.jpg here is a better ss, it has a pixel shader effect which makes it easier to see http://img38.imageshack.us/img38/8940/ss2txe.jpg (well it is still hard but believe me =P extra pixels are there) In the shader which is used while drawing the texture which scene is rendered on, if I change filters MinFilter = Linear; MagFilter = Linear; MipFilter = Linear; set these to None, problem is solved. But without filters, scene looks much worse so I am searching for a better solution =)

Share this post


Link to post
Share on other sites
Hi,

I think it comes from your full-screen quad rendering code.

How did you set up your FSQ vertices? Don't forget to shift your FSQ vertex coords (in screen space) by 0.5f.

Also, check your texture sampler definition out. When rendering full screen quads, both AddressU and AddressV must be CLAMP.

Hope this helps.
Rohat.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this