Sign in to follow this  
sunandshadow

Recommend or lend a free animal model for texturing practice

Recommended Posts

I would like to practice my texturing on a nice-looking model of an animal, preferably a horse or a big cat, but a dragon, or a wolf, anything like that would be fine. Doesn't need to be animated or anything. I want to use blender to test my textures in, so it should be compatible with that, and it would be helpful if it came with a texture I could look at as an example. I also want to be able to display my texturing attempts on my webpage, with a note that I didn't make the model, so whatever license the model has should be compatible with that. So, anyone have a model to lend or a suggestion of one I could download from somewhere, preferably without being required to create an account there? Also a recommendation for a tutorial on texture unwrapping and applying textures in blender would be cool.

Share this post


Link to post
Share on other sites
free dog,cat,mouse models: http://www.psionic3d.co.uk/?page_id=25
gimp/blender unwrapping/texturing tutorial: http://otothecleaner.free.fr/tutorials/Gimpit/gimpit1/gimpit.html

--
Ashaman

Share this post


Link to post
Share on other sites
Quote:
Original post by Ashaman73
free dog,cat,mouse models: http://www.psionic3d.co.uk/?page_id=25
gimp/blender unwrapping/texturing tutorial: http://otothecleaner.free.fr/tutorials/Gimpit/gimpit1/gimpit.html

--
Ashaman


I like this dog and I'd like to practice texturing it, but for some reason blender refuses to open the .b3d version of the file (says it is not a blender file), and when I try to import the milkshape version I mysteriously get a cube instead of anything resembling a dog. Could someone else check and see if they get the same error? I grabbed the free trial of milkshape to see if it looked okay there, and it does, but from everything I've read milkshape is buggy and terrible for trying to do texturing. The specific thing I want to do is export the wireframe of the dog unwrapped as a transparent png, and also save a version of the provided doberman texture with the wireframe superimposed on it.

Share this post


Link to post
Share on other sites
Quote:
Original post by sunandshadow
I like this dog and I'd like to practice texturing it, but for some reason blender refuses to open the .b3d version of the file (says it is not a blender file)


blender uses .blend, b3d is blitzbasic

Share this post


Link to post
Share on other sites
Quote:
Original post by Kaze
blender uses .blend, b3d is blitzbasic


Bleh, shows how clueless I am about this whole 3D art thing. :P Okay, so I opened the dog in milkshape, exported it as a wavefront object, imported that to blender, and I have a dog, yay. I split the screen, put the left half in 3D view: edit mode, and the right half in UV view, and I can see the wireframe superimposed on the dog texture, yay again. But, the wireframe is only the pure side view and appears to be missing the ears, while the texture extends beyond the wireframe to show the sides and back of the legs and other pieces. So 1. how do I get the wireframe to display matching the way the texture is wrapped onto the model, and 2. how do I then save a version of this wireframe superimposed on the texture, and the wireframe alone on a transparent background?

Share this post


Link to post
Share on other sites
Not sure exactly what you mean but if you only see one side unwrapped the texturing is probably just mirrored. To export a tga of the uv mapping go into the uv/image editor and UVs-> scripts-> save uv face layout.

Share this post


Link to post
Share on other sites
Quote:

But, the wireframe is only the pure side view and appears to be missing the ears, while the texture extends beyond the wireframe to show the sides and back of the legs and other pieces.

I can't take a look at the model at the moment, but it sounds like the dog has (accidentally) being unwrapped by a simple uv-projection.

Before unwrapping you need to mark edges as seams (seams will not be imported). Here is a short tutorial to unwrap the dog in 10 mins:

-- seams
1. go into edit mode
2. select edge mode
3. unselect all (press a until anything is selected)
4. select all edge which will half the dog
5. mark selected edges as seams(press ctrl+E -> mark as seams)
6. unselect all (3.)
6. select edges pointing inside along the legs
7. mark selected edges as seams
-- test
8. select face mode
9. unselect all
10. move the mouse over one face and press l (select linked faces)
11. if you have correctly marked all seams, one half of the dog will be selected
12. if not, try to find a "leaking" edge you have missed
-- unwrap
13. select face mode
14. select all (press a until everything has been selected)
15. press ctrl+u and select "unwrap" (top)
16. now all faces should be displayed in a more or less unwrapped way in the uv-image editor
-- save uv
17. before exporting uv coords you need to save the blend file (seems to be a bug[version 2.48]).
18. save UV now (Kaze:".. UVs-> scripts-> save uv face layout.")


You could now paint the texture and reload it. If you want to see the texture while rendering, you need to assign a material to the dog and assogm the texture to this material. After base unwrapping works you could do the following:
1. Create a test grid texture (UV window->image->new->select 'test grid').
With this test grid you could easily check for an equal distribution of texels.
2. The UV mesh can be handled like a normal mesh grid: select whole mesh parts by moving your mouse over a vertex and press l(select linked), rotate (press r), scale(press s) or move (press ? t or m, not sure).
3. You could paint directly in blender by using the texture-mode (selected from the menu where you switch between object and edit mode). Use this mode to paint in the 3d view, this will help you to find the correct location on the texture (i.e. eyes) and it is much easier to get rid of texture seams (use version 2.49). Fine tuning can be done in gimp.

--
Ashaman

Share this post


Link to post
Share on other sites
Quote:
Original post by Ashaman73
Quote:

But, the wireframe is only the pure side view and appears to be missing the ears, while the texture extends beyond the wireframe to show the sides and back of the legs and other pieces.

I can't take a look at the model at the moment, but it sounds like the dog has (accidentally) being unwrapped by a simple uv-projection.

Before unwrapping you need to mark edges as seams (seams will not be imported). Here is a short tutorial to unwrap the dog in 10 mins:

-- seams
1. go into edit mode
2. select edge mode
3. unselect all (press a until anything is selected)
4. select all edge which will half the dog
5. mark selected edges as seams(press ctrl+E -> mark as seams)
6. unselect all (3.)
6. select edges pointing inside along the legs
7. mark selected edges as seams
-- test
8. select face mode
9. unselect all
10. move the mouse over one face and press l (select linked faces)
11. if you have correctly marked all seams, one half of the dog will be selected
12. if not, try to find a "leaking" edge you have missed
-- unwrap
13. select face mode
14. select all (press a until everything has been selected)
15. press ctrl+u and select "unwrap" (top)
16. now all faces should be displayed in a more or less unwrapped way in the uv-image editor


I followed these steps (thank you very much for explaining ^_^ ) but the unwrap looks the same, incorrect. I think it will not look right unless I make more seams - should be one up the inside of each leg, one on each ear?

Edit: yes I added some more seams and now it unwraps to a good shape, although now I can't figure out how to make it apply the texture to both sides of the model, or at least pack the two sides efficiently onto the texture. Not a big problem though, since I'm not worried about efficiency or saving space at the moment. I will test color this tomorrow and try to stick it back on the model.

[Edited by - sunandshadow on August 3, 2009 7:42:03 AM]

Share this post


Link to post
Share on other sites
I handled the problem of getting the same texture applied to both sides of the model by cutting the model in half and emulating the other half with blender's mirror modifier. I exported the unwrap as an svg and test-colored it in Inkscape. However, I could not get the svg texture to import properly. I got the vectex plugin as recommended, but although the imported svg texture displayed ok in the texture preview window, it wouldn't display on the model, and when I tried 'render current scene' it crashed blender. o.O Possibly the plugin is not compatible with this newer version of blender. So I exported the .svg texture from inkscape as a png, then imported that to blender. After significantly more agony, I got that on the model and rendered it to get this:

I think somewhere along the way blender lost the changes I made to enlarge the ear and tail portions of the texture. All in all, Blender is possibly the most unintuitive program I have ever used. >.<

But now that I've made it work once, I can theoretically do so again. I want to hack on the model first, it overall has too many polys and specifically the feet are too narrow, and a nice big tail would be more fun. I could even stick horns on it or something. Then I'll redo the uv map from the edited model and try to make a real texture.

Share this post


Link to post
Share on other sites
Quote:

So I exported the .svg texture from inkscape as a png, then imported that to blender.

Stick to png or an other image format, everything else seems to be hack :)

Quote:

All in all, Blender is possibly the most unintuitive program I have ever used. >.<

Hmm.. yes,it is. But it is the best you will get for your money. It is not the most intuitive program, but got many important features only found in other professional tools.

Quote:

...it overall has too many polys ...

Hmm, certainly depends on your target platform. On modern PC this poly count (I would guess 1.5k) is a joke.
Nevertheless, the best, but slowest, way to reduce your polycount is by hand, but there're two other options available in blender.
1. decimate modifier: The fastest and most interactive way to reduce the polycount. But it got not the best quality and sometimes it produces artifacts.
2. edit mode->mesh menu->script->poly reduction
This is a nice script which has good quality, but once you have done your reduction it is fix. Btw. you don't need to adjust your uv mapping after reduction.

--
Ashaman


Share this post


Link to post
Share on other sites
Ugh, now what? -_- I edited the model to put a tail on it, and it actually looks pretty good, but when I try to UV unwrap it it comes out with the tail huge and the body of the dog small. o.O

Quote:
Original post by Ashaman73
Quote:

All in all, Blender is possibly the most unintuitive program I have ever used. >.<

Hmm.. yes,it is. But it is the best you will get for your money. It is not the most intuitive program, but got many important features only found in other professional tools.

True, I have heard that blender is simply the best free 3D software, so that's why I have been trying to force myself to learn how to use it rather than looking for a different software.

Quote:

...it overall has too many polys ...

Hmm, certainly depends on your target platform. On modern PC this poly count (I would guess 1.5k) is a joke.
Nevertheless, the best, but slowest, way to reduce your polycount is by hand, but there're two other options available in blender.
1. decimate modifier: The fastest and most interactive way to reduce the polycount. But it got not the best quality and sometimes it produces artifacts.
2. edit mode->mesh menu->script->poly reduction
This is a nice script which has good quality, but once you have done your reduction it is fix. Btw. you don't need to adjust your uv mapping after reduction.

--
Ashaman[/quote]
I was just thinking that fewer larger polygons would be easier to texture than lots of tiny ones.

Share this post


Link to post
Share on other sites
Quote:

Ugh, now what? -_- I edited the model to put a tail on it, and it actually looks pretty good, but when I try to UV unwrap it it comes out with the tail huge and the body of the dog small. o.O

You most likely forgot to adjust your seams. After editing parts of your model check all seams of the modified part.

Quote:

I was just thinking that fewer larger polygons would be easier to texture than lots of tiny ones.

You are correct if you paint each single polygon by hand ;-) In most cases you paint areas of the model, i.e. one leg, independently of the number of polygons, so the outline of each area is more important than the fact that it consists of 100k polygons.

--
Ashaman

Share this post


Link to post
Share on other sites
Aha, removing the existing seams and re-making them did fix it. :) So, now I have a workable UVmap to paint on. I threw some quick colors on it to see how it mapped onto the dog - looks terrible lol, way too shiny, but it looked like a dog, so that's win. :)

Share this post


Link to post
Share on other sites
Sun,

Try going to CGCookie.com and watching the blender tutorial movies there, then you won't have as much trouble. There is one video where a head is unwrapped for texturing, it should help you out.

Share this post


Link to post
Share on other sites
Back again with another troubleshooting question. Today I was trying out texture-painting, the kind where you paint directly on the model in the 3D view and it automatically places the colors on the UV unwrap, which can then be exported for cleanup/detailing. Anyway I discovered I seemed to have some polygons double-mapped somehow - when I painted one set (inside the ear) the other set (on top of the head) automatically got painted, and vice versa. Is this a seams problem, should I change them and re-unwrap it, or what? (I should be asking all these questions on the blender forum, but I tried to register there and haven't gotten an activation email.)

Edit: yeah it was those darn seams again, but I got it sorted out, yay me. [smile] Here's my rough draft of the texture made by painting on the model in blender. I like this way of making a rough draft of a texture a lot. :)


Now to clean up the stray white bits and add some texture to it...

[Edited by - sunandshadow on August 14, 2009 11:40:24 PM]

Share this post


Link to post
Share on other sites
You have done a nice rework on the model.

As a note, if you don't already know, to smooth your model select it, go to the editing panel (bottom windon, press F9), and press "Set Smooth" in the "Link and Materials". To got back to your current look, press "Set Solid".

--
Ashaman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this