Sign in to follow this  

Entry Point Not Found __glutInitWithExit

This topic is 3046 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've looked everywhere and tried everything but can't seem to figure this out. I was going along programming away, testing a program that uses GLUT and out of nowhere, I hit F5 to fire up a debug test and instead of seeing my program, I get this error saying that the entry point could not be found in glut32.dll. I've checked on the MSDN forums and found a few similar complaints, tried all the solutions and come up empty handed. I've restarted Visual Studio, restarted my computer and completely reinstalled the GLUT libraries. I'm using Visual Studio 2008 Express, Windows 7 and the latest GLUT library. It worked right up until it didn't. The only thing I changed was code to modify a texture and I've since stripped that out to see if I somehow screwed with the GLUT initialization. I've checked my library directories, made sure all the files were in the right place and up to date, and I'm completely lost. So, any ideas? EDIT: this can be closed. I found out the linker was grabbing an out-dated version of glut32.dll in system32 whereas I had the newer version in the windows base directory. I think when I installed the ATI SDK it added its own version of glut32.dll to the system32 directory which takes precedence over the base windows directory, on my compiler anyways. [Edited by - stevo86 on August 16, 2009 5:27:16 PM]

Share this post


Link to post
Share on other sites

This topic is 3046 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this