• Advertisement

Archived

This topic is now archived and is closed to further replies.

Texture / PixelFormat

This topic is 6031 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! I''ve got some problems with my OpenGL Wrapper for the snes emulator zsnes; everything works on nVidia TnT1+ classed adapters and on ATI Radeon (As far as I know). If the emulator is started on ANYTHING except this, I''ll just see a white box! My code is based on NeHe''s code, that works on almost every card but the only difference is that I''m using the GL_UNSIGNED_SHORT_5_6_5 taken from the GLEXT.H (I think that''s a header from the OpenGL 1.2 SDK) instead of the GL_UNSIGNED_BYTE that''s used in NeHe''s tutorials. Is there any other alternatives supported it OpenGL 1.1 SDK instead of the 1.2 SDK GL_UNSIGNED_SHORT_5_6_5?

Share this post


Link to post
Share on other sites
Advertisement
All drivers that supports 1.2 or greater should work. (Check gl12Supported = atof(glGetString(GL_VERSION)) >= 1.2; )

If 1.2 is not supported can you check if EXT_packed_pixels is supported. See
http://oss.sgi.com/projects/ogl-sample/registry/EXT/packed_pixels.txt

The MSDN documentation for glTexImage2D
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/opengl/hh/opengl/glfunc03_16jo.asp

Share this post


Link to post
Share on other sites

  • Advertisement