Jump to content
  • Advertisement
Sign in to follow this  
Typon

HLSL, Meshes are shadowing themselves :/

This topic is 3294 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey! If you have a look at this picture you will notice that my shadows is working great at the landscape. The shadow is set to 25% black on the landscape. On the meshes the shadow is set to 100% black and as you can see they are all 100% black, meaning that they get 100% shadowed. I suspect that they are selfshadowing some how. I could ofcourse turn off the shadows on everything except the landscape but the request is that I fix shadows on all of it so do you guys have any suggestions what to do? Image: http://img411.imageshack.us/img411/338/shadowself.jpg

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!